Membatasi bandwidth file tertentu pada mikrotik

Contoh kasus kita memiliki sebuah warnet atau internet perkantoran dengan IP LAN 10.10.10.0/24 nah kebetulan kita mau membatasi bandwitdh aktifitas download yang berekstensi tertentu, contohnya jika user ingin download file exe maka user akan mendapatkan bandwitdh 128 kb,   gak peduli itu pake IDM dll bagaimana caranya ? langsung aja

kita masukan dulu di mangle rule ini

/ip firewall mangle
add action=mark-connection chain=prerouting content=.exe disabled=no \
new-connection-mark=limit-content-con passthrough=yes protocol=tcp \
src-address=10.10.10.0/24
add action=mark-connection chain=prerouting content=.rar disabled=no \
new-connection-mark=limit-content-con passthrough=yes protocol=tcp \
src-address=10.10.10.0/24
add action=mark-packet chain=prerouting connection-mark=limit-content-con \
disabled=no new-packet-mark=content-terlimit passthrough=yes

OKE KALAU SUDAH DIBACA DIATAS SAYA AKAN JELASKAN SATU PERSATU RULE DIATAS AGAR SAHABAT RANAHDAMAI.ORG MENGERTI KONFIGURASI DIATAS

ADD ACTION=MARK-CONNECTION CHAIN=PREROUTING CONTENT=.EXE DISABLED=NO \
NEW-CONNECTION-MARK=LIMIT-CONTENT-CON PASSTHROUGH=YES PROTOCOL=TCP \
SRC-ADDRESS=10.10.10.0/24

ARTINYA KITA MEMBERIKAN RULE PADA CONTENT YANG BEREXTENSI .EXE ( LIHAT WARNA MERAH) ANDA BISA SAJA MEMASUKAN EKSTENSION APA AJA SAJA KALAU DIATAS SAYA HANYA KASIH CONTOH 2 SAJA .EXE DAN .RAR YANG TERPENTING NEW-CONNECTION-MARK=LIMIT-CONTENT-CON  ( NAMA INI TERSERAH ANDA YG PENTING INGAT, INI AKAN BERFUNGSI DAN BERHUBUNGAN DENGAN RULE SELANJUTNYA  JADI SEMACAM DI GRUB LAH .. EXTENSIONNYA BEDA TAPI MASUKAN GRUBNYA DALAM LIMIT-CONTENT-CON)

ADD ACTION=MARK-PACKET CHAIN=PREROUTING CONNECTION-MARK=LIMIT-CONTENT-CON \
DISABLED=NO NEW-PACKET-MARK=CONTENT-TERLIMIT PASSTHROUGH=YES

ARTINYA KITA MEMBERIKAN RULE PADA LIMIT-CONTENT-CON  UNTUK DITANDAI ATAU DINAMAI CONTENT-TERLIMIT

rule selanjutnya

/queue simple
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
disabled=no interface=ether2 limit-at=0/0 max-limit=128k/128k name=\
content packet-marks=content-terlimit parent=none priority=8 queue=\
default-small/default-small target-addresses=10.10.10.0/24 total-queue=\
default-small

ARTINYA SAYA MEMBATASI IP 10.10.10.0/24 ( LAN ) UNTUK CONTENT-TERLIMIT TADI HANYA 128 K, LALU BAGAIMANA KALAU SAYA PENGEN IP TERTENTU SAJA YG KENA RULE ITU ? JAWABANNYA   TINGGAL GANTI AJA RULENYA JGN 10.10.10.0/24 MELAINKAN 10.10.10.2 MENJADI

/QUEUE SIMPLE
ADD BURST-LIMIT=0/0 BURST-THRESHOLD=0/0 BURST-TIME=0S/0S DIRECTION=BOTH \
DISABLED=NO INTERFACE=ETHER2 LIMIT-AT=0/0 MAX-LIMIT=128K/128K NAME=\
CONTENT PACKET-MARKS=CONTENT-TERLIMIT PARENT=NONE PRIORITY=8 QUEUE=\
DEFAULT-SMALL/DEFAULT-SMALL TARGET-ADDRESSES=10.10.10.2 TOTAL-QUEUE=\
DEFAULT-SMALL

silahkan download dan amati dengan winbox pada ip- firewall- mangle

 

Leave a Reply

Your email address will not be published. Required fields are marked *